[P] Player Fails to Load Music after Fader Update

Post about any bugs or other issues that you find on AAO.

Moderator: EN - Forum Moderators

Post Reply
User avatar
¿Acid Rain?
Posts: 20
Joined: Mon Oct 09, 2017 5:12 am
Gender: Male
Spoken languages: English

[P] Player Fails to Load Music after Fader Update

Post by ¿Acid Rain? »

Hey, I've run into a issue with music following the update from (I think) yesterday, June 4, 2022. I see that this update has had bugs reported already, but I'm not sure if this issue is related to that one, so I decided to post it here.

It seems that the player now has issues loading music in trials with high framecount... or so it seems. I do not have a specific link to a specific trial wherein this problem occurs because it's happening in all of my trials over roughly 2500 frames (most of them).

For example, I have a segment that is currently 2728 frames long. It has 30 music tracks and 41 sound effects. When I playtest this trial, I am unable to get tracks 25–30 to play under any circumstances. Some of these tracks are custom, and some are native to the editor. Some have adjusted volume levels, and some do not. When I preview these tracks in the Storyboard tab, they preview fine. When the playtest is loading, everything appears to load in fine, but again, these six tracks will not play. And to be clear, this was not an issue 48 hours ago.

Similar problems occurs in other trials of mine. It's always the last half-dozen tracks or so that won't play. HOWEVER, there is a weird fix for this. If I add, for instance, five new tracks to the trial, three of the tracks that were previously broken now work just fine. Of course, these five new tracks are now the ones that don't work. (It does not seem to be 1:1 proportional, but I literally just realized I could do this as I was writing this, so I haven't tested this workaround extensively.)

I've poked around, and I think the overall size of the trial has something to do with it. I made this test trial which has 44 tracks and sound effects and as many frames, but I haven't encountered any issues with it. Also, it's worth mentioning that I haven't had any sound effect issues since the update at all.

I'm using Firefox on Windows 10.
User avatar
TimeAxis
Posts: 162
Joined: Fri Jan 01, 2021 8:27 pm
Spoken languages: English

Re: [P] Player Fails to Load Music after Fader Update

Post by TimeAxis »

This happens with music with an ID greater than the number of total music tracks in the trial (which is caused by deleting tracks). A temporary workaround for this is to add additional music tracks for all the ones you've deleted, so that the total number of tracks is at least as high as the ID of every music track you try to use. (The ID is the little number in the grey box in the corner when you add music in the editor.) That should get your tracks to load in the meantime.

I've taken a look at the code and come up with what I believe is a proper fix from what I've tested, and it's been sent as a pull request through the appropriate channels.
Image
Question Arcs (Threads Coming Soon)
ImageImageImageImage

Gaiden Episodes
Champion of Turnabouts
User avatar
¿Acid Rain?
Posts: 20
Joined: Mon Oct 09, 2017 5:12 am
Gender: Male
Spoken languages: English

Re: [P] Player Fails to Load Music after Fader Update

Post by ¿Acid Rain? »

Thanks for the quick response!
Mosy
Posts: 53
Joined: Thu Aug 02, 2018 12:01 am
Gender: Male
Spoken languages: English

Re: [P] Player Fails to Load Music after Fader Update

Post by Mosy »

TimeAxis wrote: Sun Jun 05, 2022 8:11 pm This happens with music with an ID greater than the number of total music tracks in the trial (which is caused by deleting tracks). A temporary workaround for this is to add additional music tracks for all the ones you've deleted, so that the total number of tracks is at least as high as the ID of every music track you try to use. (The ID is the little number in the grey box in the corner when you add music in the editor.) That should get your tracks to load in the meantime.

I've taken a look at the code and come up with what I believe is a proper fix from what I've tested, and it's been sent as a pull request through the appropriate channels.
Interesting... a few bugs have appeared here and there regarding music, after the update. Another example is that custom music no longer works as a preview like in this example: Image
I'm hoping for a fix soon, Ive also had losses in music loading into playing cases too.
Live life as you enjoy it, pal!- :objection:
I guess not...
Image
User avatar
TimeAxis
Posts: 162
Joined: Fri Jan 01, 2021 8:27 pm
Spoken languages: English

Re: [P] Player Fails to Load Music after Fader Update

Post by TimeAxis »

Mosy wrote: Tue Jun 07, 2022 3:46 am
TimeAxis wrote: Sun Jun 05, 2022 8:11 pm This happens with music with an ID greater than the number of total music tracks in the trial (which is caused by deleting tracks). A temporary workaround for this is to add additional music tracks for all the ones you've deleted, so that the total number of tracks is at least as high as the ID of every music track you try to use. (The ID is the little number in the grey box in the corner when you add music in the editor.) That should get your tracks to load in the meantime.

I've taken a look at the code and come up with what I believe is a proper fix from what I've tested, and it's been sent as a pull request through the appropriate channels.
Interesting... a few bugs have appeared here and there regarding music, after the update. Another example is that custom music no longer works as a preview like in this example: Image
I'm hoping for a fix soon, Ive also had losses in music loading into playing cases too.
I noticed this one as well and took a look at the code, but it was beyond me. I couldn't figure out what differentiated the editor preview from the sounds/tracks being played in the trial (which do work). Looked the same to me. My guess is that whatever magic Enthalpy pulled off to make the audio in the trial fall back on HTML5 when CORS fails, he only did in the player and not the editor. But I wasn't able to find that.

As a workaround though, if you're hosting on github (or some other server that allows CORS), the previews will work (if they don't, you might be using the wrong URL). The preview bug is a pretty minor bug, since the tracks still work in the trial, just a slight inconvenience.
Image
Question Arcs (Threads Coming Soon)
ImageImageImageImage

Gaiden Episodes
Champion of Turnabouts
Mosy
Posts: 53
Joined: Thu Aug 02, 2018 12:01 am
Gender: Male
Spoken languages: English

Re: [P] Player Fails to Load Music after Fader Update

Post by Mosy »

TimeAxis wrote: Tue Jun 07, 2022 7:58 am
Mosy wrote: Tue Jun 07, 2022 3:46 am
TimeAxis wrote: Sun Jun 05, 2022 8:11 pm This happens with music with an ID greater than the number of total music tracks in the trial (which is caused by deleting tracks). A temporary workaround for this is to add additional music tracks for all the ones you've deleted, so that the total number of tracks is at least as high as the ID of every music track you try to use. (The ID is the little number in the grey box in the corner when you add music in the editor.) That should get your tracks to load in the meantime.

I've taken a look at the code and come up with what I believe is a proper fix from what I've tested, and it's been sent as a pull request through the appropriate channels.
Interesting... a few bugs have appeared here and there regarding music, after the update. Another example is that custom music no longer works as a preview like in this example: Image
I'm hoping for a fix soon, Ive also had losses in music loading into playing cases too.
I noticed this one as well and took a look at the code, but it was beyond me. I couldn't figure out what differentiated the editor preview from the sounds/tracks being played in the trial (which do work). Looked the same to me. My guess is that whatever magic Enthalpy pulled off to make the audio in the trial fall back on HTML5 when CORS fails, he only did in the player and not the editor. But I wasn't able to find that.

As a workaround though, if you're hosting on github (or some other server that allows CORS), the previews will work (if they don't, you might be using the wrong URL). The preview bug is a pretty minor bug, since the tracks still work in the trial, just a slight inconvenience.
Code is quite fascinating, one small mistake and an entire fleet of problems can sprout. Weird part is that I actually use Github for all my sound files and I'm still having the problem, so its kinda weird XD. Hope they can find the source of the issues!
Live life as you enjoy it, pal!- :objection:
I guess not...
Image
User avatar
Enthalpy
Community Manager
Posts: 5119
Joined: Wed Jan 04, 2012 4:40 am
Gender: Male
Spoken languages: English, limited Spanish

Re: [P] Player Fails to Load Music after Fader Update

Post by Enthalpy »

We have a fix in development, and with the fix, I haven't been able to reproduce the problem with audio previews not playing for custom tracks.
[D]isordered speech is not so much injury to the lips that give it forth, as to the disproportion and incoherence of things in themselves, so negligently expressed. ~ Ben Jonson
Mosy
Posts: 53
Joined: Thu Aug 02, 2018 12:01 am
Gender: Male
Spoken languages: English

Re: [P] Player Fails to Load Music after Fader Update

Post by Mosy »

Enthalpy wrote: Thu Jun 09, 2022 3:31 am We have a fix in development, and with the fix, I haven't been able to reproduce the problem with audio previews not playing for custom tracks.
Oh wow, that's weird, me and a few of my friends all have this issue, where they cannot hear previews... Hopefully the fix gets it! ^^
Live life as you enjoy it, pal!- :objection:
I guess not...
Image
nemolee.exe
Posts: 7
Joined: Sun Aug 26, 2018 11:53 pm
Gender: Male
Spoken languages: English, Korean

Re: [P] Player Fails to Load Music after Fader Update

Post by nemolee.exe »

I believe to have that same problem. I am currently working on a 400+ trial as of right now, and I have issues having 3 of the songs to play. Please fix this issue immediately!
User avatar
TimeAxis
Posts: 162
Joined: Fri Jan 01, 2021 8:27 pm
Spoken languages: English

Re: [P] Player Fails to Load Music after Fader Update

Post by TimeAxis »

nemolee.exe wrote: Sat Jun 11, 2022 5:13 pm I believe to have that same problem. I am currently working on a 400+ trial as of right now, and I have issues having 3 of the songs to play. Please fix this issue immediately!
If waiting for the fix (which is coming) isn't an option for you for some reason, like I said, a temporary workaround is to just add more tracks. Just keep adding more music (without using it) until the songs play. You can remove them later after the fix drops.
Image
Question Arcs (Threads Coming Soon)
ImageImageImageImage

Gaiden Episodes
Champion of Turnabouts
User avatar
Unas
Admin / Site programmer
Posts: 8850
Joined: Tue Jul 10, 2007 4:43 pm
Gender: Male
Spoken languages: Français, English, Español
Contact:

Re: [P] Player Fails to Load Music after Fader Update

Post by Unas »

The fix has been loaded today, please check if you still experience this issue :-)
ImageImageImage
If knowledge can create problems, it is not through ignorance that we can solve them.
Si le savoir peut créer des problèmes, ce n'est pas l'ignorance qui les résoudra. ( Isaac Asimov )
XavierWright
Posts: 65
Joined: Tue May 18, 2021 8:43 pm
Gender: Male
Spoken languages: English

Re: [P] Player Fails to Load Music after Fader Update

Post by XavierWright »

Well, the sound bar still comes up red for some cases but the music that stopped functioning before works again so I think it's fine
User avatar
¿Acid Rain?
Posts: 20
Joined: Mon Oct 09, 2017 5:12 am
Gender: Male
Spoken languages: English

Re: [P] Player Fails to Load Music after Fader Update

Post by ¿Acid Rain? »

Unas wrote: Sun Jun 19, 2022 6:06 pm The fix has been loaded today, please check if you still experience this issue :-)
The problem has been fixed, best I can tell. Thank you!
User avatar
Enthalpy
Community Manager
Posts: 5119
Joined: Wed Jan 04, 2012 4:40 am
Gender: Male
Spoken languages: English, limited Spanish

Re: [P] Player Fails to Load Music after Fader Update

Post by Enthalpy »

XavierWright wrote: Sun Jun 19, 2022 6:20 pm Well, the sound bar still comes up red for some cases but the music that stopped functioning before works again so I think it's fine
Try clearing your cache.
[D]isordered speech is not so much injury to the lips that give it forth, as to the disproportion and incoherence of things in themselves, so negligently expressed. ~ Ben Jonson
Mosy
Posts: 53
Joined: Thu Aug 02, 2018 12:01 am
Gender: Male
Spoken languages: English

Re: [P] Player Fails to Load Music after Fader Update

Post by Mosy »

Unas wrote: Sun Jun 19, 2022 6:06 pm The fix has been loaded today, please check if you still experience this issue :-)
Thank you so much Mr. Unas! works like a charm once again <3 (Only now sometimes the music and sound keep on playing even when taking off the mouse. :shock: )
You're the best.
Live life as you enjoy it, pal!- :objection:
I guess not...
Image
Post Reply